Security researchers have discovered a serious security flaw in Linux kernel that would appear to have existed since 2009. The vulnerability, CVE-2017-2636, rated ‘high’ on the National Vulnerability Database (NVD) could allow local users to gain privileges or cause a denial of service. According to The Hacker News, it affects a large number of Linux distributors, including Red Hat, Debian, Fedora, OpenSUSE, and Ubuntu. Users are advised to install the latest security updates right away. The discovery was made by Alex Popov of Positive Technologies. Patrick Carey, is a director at Black Duck Software commented below.

Patrick Carey, Director at Black Duck Software:

Patrick Carey“This vulnerability disclosure has all the traits that make open source vulnerability management challenging for almost every team that builds or runs software today.  Firstly, it’s a security flaw in a widely used open source component, in this case the Linux kernel itself. Secondly, the vulnerability has existed in the code for several years. Thirdly, it was discovered by a professional security researcher, not by an off-the-shelf static or dynamic application security tool. And fourthly, the only way most Linux users will know about it is if they are actively monitoring the NVD or a security feed from their Linux provider.”

“Given this, it’s highly likely that thousands of systems remain un-patched and vulnerable.  With nearly 10 vulnerabilities like this being disclosed every week across over 2 million open source projects, if organisations aren’t making a concerted effort to track and manage their open source, they are leaving the door wide open for exploit.”

Information Security Buzz